Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Getting started with the SDK
DJMatty
post Aug 14 2006, 08:08 AM
Post #1


Member
**

Group: Members
Posts: 11
Joined: 14-August 06
Member No.: 124



Hi

I've just started to play with the AMIP SDK and I'm having problems getting it to do anything.

I have AMIP running in winamp, its changing my Messenger np message, and also creating a file, so it's running ok. I can also telnet to port 60333 on my pc and that gets connected, but doesn't do much else when I type stuff.

However when I use the SDK the ac_init_client returns 1, but the ac_eval returns 3 (CONNECTIONFAILED).

Here is the code i am using, this was built using VS2005, it's simple console app.

CODE
#include "stdafx.h"
#include <windows.h>
#include <stdio.h>
#include <conio.h>
#include "ac.h"

#pragma comment(lib, "ac.lib")


int _tmain(int argc, _TCHAR* argv[])
{
    int err = ac_init_client("127.0.0.1", 60333, 1000, 5, 1);

    if(err == 1)
    {
        char np[2048];

        err = ac_eval("var_name",np);

        if(err == AC_ERR_NOERROR)
        {
            printf("Now playing %s\n", np);
        }
        else
        {
            printf("Error: %d\n", err);
        }
    }

    ac_uninit();

    _getch();

    return 0;
}


Can anyone see anything obviously wrong? Do I need a specific version of AMIP to work with the SDK? (I'm using 2.53 beta at present)

I've also downloaded the java sdk and tried the example bat file, that also throws a ConnectionFailedException so I'm guessing it's not to do with my code but how I've got AMIP set up or how the SDK is set up... can anyone point me in the right direction?

Thanks

Matt
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Serge
post Aug 14 2006, 10:39 AM
Post #2


AMIP Developer
***

Group: Root Admin
Posts: 935
Joined: 12-March 06
Member No.: 1



Please check that you have latest AMIP beta running, the file date (amip.dll or gen_irc.dll) should be 2006-07-24.

Also get some tool like netstat and check that it's AMIP lisening on port 60333, not some other application.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
DJMatty
post Aug 14 2006, 04:34 PM
Post #3


Member
**

Group: Members
Posts: 11
Joined: 14-August 06
Member No.: 124



Hi Serge

I only have the gen_irc.dll in my plugins folder, it's date is 17-04-2006 and version is '2.5.3.0'.

I've used the TCPView tool from sysinternals, I can see winamp.exe listening on 60333, and when I telnet to it I can see the connection is created, however when I run my app, nothing is connected when I execute ac_init_client, and nothing is connected when i execute ac_eval... ac_eval returns immediately with an error.

I'll re-download the beta and try that.

Thanks

Matt

QUOTE(Serge @ Aug 14 2006, 11:39 AM) *

Please check that you have latest AMIP beta running, the file date (amip.dll or gen_irc.dll) should be 2006-07-24.

Also get some tool like netstat and check that it's AMIP lisening on port 60333, not some other application.

User is offlineProfile CardPM
Go to the top of the page
+Quote Post
DJMatty
post Aug 14 2006, 04:44 PM
Post #4


Member
**

Group: Members
Posts: 11
Joined: 14-August 06
Member No.: 124



Hi Serge

Just to let you know, i've downloaded the latest beta, gen_irc.dll is now 24/07/2006, but I'm still getting the same problem.

ac_init_client returns 1 and ac_eval returns 3...

Is there anything else I can try?

Thanks

Matt
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Serge
post Aug 14 2006, 06:57 PM
Post #5


AMIP Developer
***

Group: Root Admin
Posts: 935
Joined: 12-March 06
Member No.: 1



Your sample works fine on my PC. Please try the attached version that I've compiled. Just unpack and use with the supplied ac.dll.


Attached File(s)
Attached File  actest.zip ( 228.81k ) Number of downloads: 1476
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
DJMatty
post Aug 15 2006, 01:14 PM
Post #6


Member
**

Group: Members
Posts: 11
Joined: 14-August 06
Member No.: 124



Hi Serge

That works great here on my work PC... I'll try it at home tonight and that will see if I have got a problem trying to build it in VS2005... or a problem with my install of winamp\amip at home...

Thanks for your help!

Matt
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
DJMatty
post Aug 16 2006, 12:34 AM
Post #7


Member
**

Group: Members
Posts: 11
Joined: 14-August 06
Member No.: 124



Hi Serge

Just to let you know I've got it going on my PC at home with VS2005. I ended up removing the shoutcast dsp from winamp, and reinstalling that (not sure if it is a red herring), I also have some odd things going on with the ip addresses.

If amip API is running on 0.0.0.0 (as set in the configurator) I can only init the client on 127.0.0.1 for it to work... if I try to use my actual IP address 192.168.7.20 this fails with error code 3. And it seems to fail with this error code in any other combination that I have tried, like setting it to listen on 192.168.7.20 in the configurator and connecting my client to it on that address. Strange.

Anyway, its working ok now, and I'm reading playlists and getting events etc.

Oh and if anyone is interested in a C# wrapper for the SDK then let me know as I've built one for it.

Cheers

Matt
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Serge
post Aug 16 2006, 10:10 AM
Post #8


AMIP Developer
***

Group: Root Admin
Posts: 935
Joined: 12-March 06
Member No.: 1



Thanks for the information, such problem may be caused by a firewall.
If you want, I can include your C# wrapper in the AMIP SDK distribution.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
DJMatty
post Aug 16 2006, 04:57 PM
Post #9


Member
**

Group: Members
Posts: 11
Joined: 14-August 06
Member No.: 124



Hi Serge

Good point. I checked that windows firewall is disabled and I don't run any other personal firewall software so it should be ok... oh well.

I'll tidy up the c# wrappers and the example app and attach it to this thread for you.

Cheers

Matt
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
DJMatty
post Aug 16 2006, 11:33 PM
Post #10


Member
**

Group: Members
Posts: 11
Joined: 14-August 06
Member No.: 124



Hi Serge

Here's the .NET wrapper and an example project that uses it.

Cheers

Matt


Attached File(s)
Attached File  AMIPClient.zip ( 209.21k ) Number of downloads: 1579
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Serge
post Aug 17 2006, 12:04 AM
Post #11


AMIP Developer
***

Group: Root Admin
Posts: 935
Joined: 12-March 06
Member No.: 1



Thank you!
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
xxpor
post Sep 4 2006, 03:34 PM
Post #12


Newbie
*

Group: Members
Posts: 1
Joined: 4-September 06
Member No.: 145



could you repost that file, it is corrupted
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
DJMatty
post Sep 4 2006, 05:53 PM
Post #13


Member
**

Group: Members
Posts: 11
Joined: 14-August 06
Member No.: 124



PM me your email and I will mail it directly... not sure why it would be corrupted though, i've just downloaded it and opened it in powerarchiver and it's fine.

Matt
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Serge
post Sep 25 2006, 01:29 PM
Post #14


AMIP Developer
***

Group: Root Admin
Posts: 935
Joined: 12-March 06
Member No.: 1



As for the IP binding problem, it's fixed in the recent beta released 24 September 2006. Due to a bug the binding worked only on 127.0.0.1.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
DJMatty
post Sep 26 2006, 01:55 PM
Post #15


Member
**

Group: Members
Posts: 11
Joined: 14-August 06
Member No.: 124



Great!

I'll download it and try it out when i'm back on a quick connection.

Thanks for letting me know!

Matt
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members: