Printable Version of Topic

Click here to view this topic in its original format

AMIP Community _ Bug Reports _ UTF bug? or other text encoding bug

Posted by: Drako60 Aug 14 2006, 09:22 AM

I have a problem with AMIP when using certain korean text formated tags, it doesn't seem to happen on mp3s, but it does happen on m4a files.

this occurs in amip.dll and crashes all of foobar2000 v0.9.2, i don't have problems with other text formats or even korean in mp3 tags.

Posted by: Serge Aug 14 2006, 09:29 AM

Please provide a sample file that can illustrate the problem.

Posted by: Drako60 Aug 14 2006, 09:41 AM

hmmm, i'm looking into this and i'm not sure i can provide with a file, ok i figured out how to do it, also i figured out where the problem is stemming from.

While foobar has no problems with it, AMIP has a problem with the file name, not that ID Tag itself, winrar also seems to suffer from the same problem, it reads the file name as 06 __ ____.m4a

I had to zip it to maintain the file name, let me know if the link doesn't work

Posted by: Serge Aug 14 2006, 09:45 AM

Tried it. Latest AMIP 2.53 beta and foobar do not crash. Sorry, I can't reproduce the issue.

Posted by: Drako60 Aug 14 2006, 10:08 AM

hmm it still crashes on me and i just updated both amip and foobar to latest version.

Hrmm i wonder what would cause it to crash on mine

I uploaded two more files that it crashes on if you wish to try those as well

I do have one system setting i'm going to test.

Posted by: Drako60 Aug 14 2006, 10:48 AM

ok i somewhat tracked this done but now i'm highly confused.

Ok system setup, I have asian and complex languages installed, and under regional and language options, advanced tab, I have non-unicode programs set to Japanese(my default) if i set it to English (United States) or have it on japanese it crashes giving me the cause as amip.dll if i set it to Korean it does not crash.

I have one other program that gives me the error "Run time erorr "5", invalid procedure or aurgument.

Winrar sees the file name as "06. __ ____.m4a"

I've also confirmed that it does not happen using the same filename on mp3s.

So i can't say its a bug in amip, but i'm confused on just where the bug comes from.

Posted by: Coren Aug 21 2006, 04:52 PM

Yup, looks like I'm having the exact same problem, only with Japanese song titles.
I switched non-Unicode programs to Japanese and that seemed to work. I just hope it won't screw up other applications.

In case you find something new, Drako, feel free to post it here, it'd be of help for me too.


Posted by: Coren Sep 4 2006, 04:16 PM

QUOTE(Coren @ Aug 21 2006, 06:52 PM) *

I switched non-Unicode programs to Japanese and that seemed to work. I just hope it won't screw up other applications.

Actually, this screwed up my homebanking software so this solution is not an option. I just have to turn AMIP off every time I listen to Japanese songs. It sucks, but that's all I can do for now.


Posted by: Garret Jan 14 2010, 07:44 AM

Have the same problem, non-Unicode programs is set to Russian and amip crashes.

Posted by: Serge Jan 14 2010, 08:29 AM

Please provide the sample file. Can you reproduce it with 2.66?

Posted by: Garret Feb 16 2010, 01:28 PM

I found out that 2.66 don't crash with mp3 files,
but crashes if i'm playing mp4 file with video content in it.

(Have some music video clips and playing it with foobar)

Posted by: Serge Feb 16 2010, 06:17 PM

Please check the 2.67 version. Send the crash dump produced by foobar and the sample file so that I can reproduce the problem.

Posted by: xumi Feb 22 2010, 03:11 PM

i got the error again :/

all seems to be in nor asian nor cirilic chararacters

the error I got is this:

Problem signature:
Problem Event Name: BEX
Application Name: foobar2000.exe
Application Version:
Timestamp implementation: 4b486cb3
Fault Module Name: amip.dll
Fault Module Version:
Timestamp Fault Module: 4b63548c
Exception Offset: 000b5954
Exception Code: c000000d
Exception Details: 00000000
OS Version: 6.1.7600.
Locale ID: 13,322
Additional Information 1: 7efe
Additional Information 2: 7efeeabb549d029af5f57262d810d484
Additional Information 3: 7ead
Additional Information 4: 7eadd80241b1db9840d25e1baf9d5151

this is the file path "F:\The Killers ALAC\Live, EP`s, Сompilations & Other\2007 - Sawdust (Compilation Album)\02 - Shadowplay.m4a"

The file is an alac file of 29.4 MB I cand upload it somewhere if you need it.

here is a screenshot of the tags of the file, however i tried deleting tags ans the error ocurred anyways. ->

I convert it to mp3 and put it in the same folder and no error ocurred.

thanks in advance


foobar v1.0
aimp v2.67

Posted by: fade Feb 11 2011, 01:36 PM

I have the same problem, I think. Details are below:


Problem signature:
  Problem Event Name:    BEX
  Application Name:    foobar2000.exe
  Application Version:
  Application Timestamp:    4b486cb3
  Fault Module Name:    amip.dll
  Fault Module Version:
  Fault Module Timestamp:    4b63548c
  Exception Offset:    000b5954
  Exception Code:    c000000d
  Exception Data:    00000000
  OS Version:    6.1.7600.
  Locale ID:    1033
  Additional Information 1:    8872
  Additional Information 2:    88723fbca6d6d96407771ee6799f455f
  Additional Information 3:    e6a3
  Additional Information 4:    e6a393ef90a71de93a9ddd63505a8068

Tag info:
IPB Image

the file format is .m4a

Thanks in advance

Posted by: Serge Feb 11 2011, 03:55 PM

Can you share the file?

Powered by Invision Power Board
© Invision Power Services